Готовая сборка Apache для Windows XP

В инструкции «Установка Apache, PHP, MySQL и phpMyAdmin на Windows XP» показано, как установить и настроить Apache для Windows XP. В результате следования этой инструкциии, создаётся папка с сервером. Я запаковал эту папку в архив, добавил туда три батника для установки, удаления и управления веб-сервером.

Этот файл вы можете скачать по ссылке: https://apache-windows.ru/files/MiAl_ServerXP.zip

Напомню, что там следующие компоненты:

  • Apache 2.2.25
  • PHP 5.4.9
  • MySQL 5.5.61
  • phpMyAdmin 3.5.8.2

Более новые версии просто физически невозможно запустить на Windows XP.

Для работы веб-сервера необходим «Распространяемый пакет Microsoft Visual C++ 2008 (x86)» - скачайте и установите его.

WAMP для Windows XP

Содержимое архива (папку Server) необходимо распаковать в корень диска C.

После распаковки, перейти в каталог c:\Server\manage\ и запустить файл install_and_start_server.bat.

Всё! Сервер установлен и готов к работе! Для проверки работоспособности сервера, наберите в браузере http://localhost/

phpMyAdmin доступен по адресу http://localhost/phpMyAdmin/

Каталог для сайтов: c:\Server\data\htdocs\

Если папку Server поместить на другой диск или переименовать её (либо иные папки в данном пакете), то сервер работать не будет. Т.к. в конфигурационных файлах прописаны абсолютные пути.

В каталоге c:\Server\manage\ имеется файл RUN.bat Данный файл включает в себя набор скриптов, которые позволяют:

  • перезапустить сервер;
  • удалить сервер;
  • установить сервер;
  • и пр.

Полное удаление сервера

Перейдите в каталог c:\Server\manage\ и запустите файл delete_server.bat.

Удалите каталог c:\Server.

Comments

  1. на winxp ставил xampp 1.8.2, там apache 2.4.10,

    это ведь новее 2.2.25? или я не так понимаю версии апачи?

    1. Установить-то не проблема. А запускать пробовали? А PHP проверяли?

      Я не придумал информацию о несовместимости версий — для каждой программы всё из официальной документации.

      1. Да, конечно запускал. Я на него и вордпресс ставил и другие веб-приложения, изучал на нем php. Поскольку я новичек в вебе разработке, возможно я не докапался до его ошибок, может быть они глубже. Но в целом вяглядит рабочим.

        1. Возможно, зависит каким компилятором собирались бинарные файлы — на самом деле, я не проверял более новые версии на Windows XP. Информацию брал из официальной документации. Хотя я всё равно не понимаю, как они могли работать, если для их запуска нужен Распространяемый пакет Microsoft Visual C++ определённой версии, а на XP установить его невозможно…

          Но всё может быть, конечно.

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *